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2.0 Introduction

Radar is a real-time interactive graphical application for remotely monitoring one o
more Radiator Radius servers. Radar allows administrators to remotely monitor, ana
and change the behaviour of Radiator.

Radiator is a highly portable and configurable Radius server from Open System C
sultants Pty. Ltd. (see http://www.open.com.au/radiator). Radar is a separate prod
(see http://www.open.com.au/radar) which may come bundled with your Radiator p
chase.

Radar makes an authenticated TCP connection to one or more Radiators. It period
checks the health of each connected server and provides tools for monitoring, analy
and changing the behaviour of each Radiator.

Using Radar, administrators can:

• Receive notification of Radiator problems by email, external programs or GUI
popup windows.

• View error and message logs.

• Enable message logging direct to a Radar window. Temporarily turn on debugg
only when it is required.

• Plot over 20 statistical measures such as Total requests, Average response tim

• Plot statistics for the server as a whole, or for individual Client, Realm, Handler
AuthBy or Host clauses.

• Remotely restart Radiators.

• View and Change the value of selected Radiator configuration parameters.

The rest of this document describes how to install, configure and operate Radar. T
intended audience is experienced network administrators who are responsible for 
taining a Radiator installation.
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3.0 Quick Start and Evaluation guide

For the keen and experienced administrator, this section contains very brief instruc
for getting started with Radar. More detailed instructions for installing, configuring a
using Radar are found in later sections.

1. Confirm you have perl (version 5.6.0 or later) and Tk (version 800.023 or later)
installed.

2. Download, install and configure Radiator 3.0 or later.

3. Add a <Monitor> clause to your Radiator configuration file. See goodies/monitor.
in your Radiator distribution for instructions and examples, or see Section 6.0,
“Radiator configuration,” on page 7 of this manual for a simple example <Monito
clause. The <Monitor> clause  allows Radar to connect to Radiator.

4. Start your Radiator.

5. Unpack your Radar distribution. Use gunzip and tar on Unix. Use WinZip on Wi
dows.

6. Change directory to the unpacked Radar distribution.

7. Run the command:
perl radar
You should see the Radar main window appear.

8. Choose File->Monitor a new Radiator server. Enter Radiator server host and po
details, then username and password. Make sure username and password ma
configuration in the Monitor clause above. The server should appear in the serve
on the left hand side of the window in green.

9. Click on the server name. Choose Tools->Trace Log. You should see a messag
window appear in the tools area on the right. Change the log level with the optio
menu.

10.Click on the server name. Choose Tools->Plot Statistics. You should see a plot
window appear in the tools area on the right. Click Properties... to plot other sta
tics from the server, or to change the plotter behaviour.

11.Choose File->Change Radar Configuration... to view and change Radar and
announcements behaviour.

12.Choose File->Save Radar Configuration, so the next time you start Radar, you 
monitor the same servers with the same tools.

4.0 Deployment Architecture

Radar is an interactive graphical application which can display on Microsoft Windo
or on any X windows display.

Since Radar is a well behaved X windows application (on Unix), and because it co
nects to Radiator by TCP, there is a great deal  of flexibility with where you can de
Radar in relation to your Radiators and your display workstations.
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4.1 Single Host

In the simplest architecture, you might have a single computer (with its own displa
running both Radiator and Radar. The host could be any Unix or Windows compute
this case, you would configure Radar to monitor the single Radiator at localhost:90
and Radar would display on the host computer’s display.

FIGURE 1. Example single host deployment architecture

4.2 Multi Host

In a larger and more complicated installation, you might have multiple independen
Radiators running on several different hosts throughout your network. You could th
run Radar on your personal workstation. Radar would connect by TCP to each Rad
and display itself on your workstation, allowing you to monitor all the Radiators fro
one location.

Radar

Radiator

NASes

Radius protocol
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FIGURE 2. Example multi host deployment architecture

4.3 Remote display

You might want to use Radar from a remote or home workstation, but security and
walling issues may mean that you can’t make a Radar connection on TCP port 90
from home to your Radiators. In that case, you could run Radar on an internal host,
use an SSH forwarded X windows connection to display Radar’s window on your ho
computer.

FIGURE 3. Example remote display deployment architecture

Radar workstation
Radiator Hosts NASes

Radius protocol

Radius protocol

Radius protocol

Radar protocol

Home workstation Radar host Radiator host

Radar protocolDialup connection, ssh login with
X11 forwarding

X11 display protocol

with X windows display
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5.0 Installation

Radar is a well-behaved perl application, and is packaged as a conventional perl d
bution, which may be installed on Unix or Windows An RPM package suitable for m
Linux versions is also available.

5.1 Requirements

• Any Unix or Windows computer with a graphical display (X windows on Unix)

• Radiator 3.0 or later

• Perl 5.6.0 or later

• Perl TK 800.023 or later

• Net::SMTP (if using email announcements)

• Approximately 4 MB of disk space

5.2 Unix

1. Ensure that Perl 5.6.0 or later is installed

2. Ensure that Perl TK 800.023 or later is installed

3. Unpack the distribution in a work area with
zcat Radar-1.0.tgz|tar xvf -

4. cd Radar-1.0

5. perl Makefile.PL

6. make

7. make test

8. Log in as, or su to root:
make install

9. Any user can now run Radar by typing:
radar

5.3 RPMs

The Radar RPM package is suitable for use with RedHat 7, SuSE and other linux 
butions.

1. Log in as root

2. Ensure that Perl 5.6.0 or later is installed

3. Ensure that Perl TK 800.023 or later is installed

4. rpm -Uvh Radar-1.0-1.noarch.rpm

5. Any user can now run Radar by typing:
radar

5.4 Windows

The Radar Makefile.PL includes support for Windows systems without nmake.
6 of  27 Radar Reference Manual
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1. Download and install ActivePerl from http://www.ActiveState.com/ActivePerl. Du
ing installation, accept all the defaults. Allow setup to reboot your computer if it
needs to.

2. Connect your computer to the Internet so you can download any required Perl 
ules from ActiveState using PPM.

3. Double click on c:\perl\bin\ppm (the Perl package manager). You will get a com
mand line screen running ppm with aPPM> prompt.

4. Type the command:
install Tk
The perl Tk module wil be installed for you.

5. Close the PPM window. Perl and Perl Tk is now installed.

6. Unpack your Radar distribution to a suitable location. Recent versions of WinZi
can be used to decompress and unpack the distribution file.

7. Start an MSDOS command window, change directories to the place where you
unpacked Radar.

8. Typeperl Makefile.PL . This will check that your distribution is complete.

9. Run the regression tests withperl test.pl . You should see some lines like “ok
xx”, and none saying “not ok xx”.

10. Install Radar by typing:
perl Makefile.PL install

11.You can now run Radar by typing
radar

6.0 Radiator configuration

Before Radiator will accept connections from Radar, it must be properly configured
include a <Monitor> clause. If there is no <Monitor> clause in the Radiator configu
tion file, Radar will not be able to connect to and monitor that Radiator.

For more extensive details on options for the <Monitor> clause, see the Radiator r
ence manual. However, below is a minimal <Monitor> clause that will permit some
tial testing. It will permit Radar to connect from anywhere to the default TCP port o
9048, using the username ‘mikem’ and password ‘fred’.

<Monitor>
Username mikem
Password fred

</Monitor>

Hint : You can control the username, password, authentication method and much m
with parameters in the <Monitor> clause. See the Radiator reference manual for m
details.

Hint : If you change your Radiator configuration, you will need to restart Radiator
before the new configuration comes into effect.
Radar Reference Manual 7 of 27
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7.0 Operation

This section describes how to start, run, configure and use Radar.

7.1 Command line arguments

Radar understands a number of command line arguments:

radar [-h] [-v] [-d] [-i inifile] [tk options]

• -h
Print usage text and exit.

• -v
Print Radar version number and exit.

• -d
Debug, print out details of commands sent to and from each Radiator, plus othe
Radar debugging detail. Useful only for Radar maintainers and customisers.

• -i inifile
Specifies an alternative configuration file location. The default location is .radar
in the users home directory on Unix, and radar.ini in the current directory on Wi
dows.

• tk options
Radar understands all the generic Tk options such as -background, -class, -dis
-font, -foreground, -geometry, -iconic, -motif.

Examples:

Run radar on Unix with the default config file:

radar

Run radar on Microsoft Windows with a common configuration file location:

radar -i c:\radar.ini

Run radar on Unix, starting with a custom config file, the window at 800 pixels wid
and 400 pixels high in the top left corner of the display on 10.1.1.2:

radar -i /share/radar.ini -geometry 800x400+0+0 -display
10.1.1.2:0.0

7.2 Configuration

You can change and adjust many Radar configuration parameters with:

• File->Edit Radar Configuration

• Select a server, use Tools->Properties

• On a logger, change the logging level menu

• On a plotter, use the Properties... button
8 of  27 Radar Reference Manual
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When Radar starts up, it attempts to restore its previous configuration from a confi
tion file. The default location of the Radar configuration file is:

• .radar.ini in your home directory on Unix

• radar.ini in the current directory on Windows

The location of the configuration file can be changed with the -i flag (see Section 7
“Command line arguments,” on page 8).

Radar can save its configuration to the configuration file, so that each time you sta
Radar, it will start up with the same configuration as before, monitoring the same s
ers, and with the same loggers and plotters visible.

By default, Radar only saves its configuration when you select File->Save Radar C
figuration. However, if you enable ‘Auto Save Configuration’ in File->Edit Radar Co
figuration..., under the General tab, then Radar will save the new configuration eve
time the configuration is changed.

Caution: The configuration file may contain Radiator access passwords. If so, ensu
the configuration file is suitably protected against access by unauthorized personn

Hint : In order for Radar to start next time with the same configuration, save the cu
configuration with File->Save Radar Configuration, or set Auto Save Configuration
File->Edit Radar Configuration, General tab.

The following configuration options are available under the File->Edit Radar Configu
tion menu:

7.2.1 General

• Skip Splash Screen
Causes Radar not to display its splash screen when it starts up. By default, the s
screen is displayed.

• Auto Save Configuration
If this is set, Radar will automatically save its configuration whenever you chang
the configuration. If it is not set, the configuration will only be saved of you choo
File->Save Configuration File. By default it is not set.

7.2.2 Announcements
Radar can alert you with an ‘announcement’ whenever certain events (both good a
bad) occur. You can tell it how to alert you with a different method for each type of
event.

Radar can announce the following events:

• connected
Radar has successfully connected or reconnected to a Radiator. This is a norma
correct event.

• disconnected
Radar has become disconnected from a Radiator. This usually means that the 
Radar Reference Manual 9 of 27
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tor has exited, or there is some network or TCP connectivity problem between Ra
and Radiator. Radar will periodically attempt to reconnect. (The time between
reconnection attempts is given by the ‘Ping interval’ parameter in the host’s Too
>Properties dialog).

• loggedin
Radar has successfully connected to and logged in to a Radiator. This is a norm
and correct event.

• stalled
A Radiator is still connected by TCP to Radar, but it has stopped responding to
Radar commands for more than a certain period of time. (The period is set by t
‘Stalled Time’ parameter in the host’s Tool->Properties dialog). This generally in
cates a problem with the Radiator, since it will probably not be responding to Rad
requests either.

• clock_skewed
A Radiator’s local clock disagrees with the Radar host’s clock by more than a cer
amount. (The amount is set by the ‘Max clock skew’ parameter in the host’s Too
>Properties dialog). This can be a problem, because it might mean that accoun
data is recorded inaccurately.

• connect_failed
Radar has attempted to reconnect to a Radiator but failed. Repeated failures d
the same reason will only be announced once. This is usually due to the target
ator not running, or a network or TCP connectivity problem.

For each type of event, you can tell Radar what method(s) to use to alert you. You
choose one or more of the following:

• Beep
Beeps or rings the bell on the display.

• Popup Window
Pops up a non-modal window with text describing the event. Click on OK to ma
the window disappear.

• Email
Send email to a designated address. You can configure the To: address, From:
address and the SMTP server to use. If To: is not set, sends email to ‘radar’. If Fr
is not set, marks the mail as from the current user. If SMTP Server: is not set, u
the mail server on the local host. The Subject is set to ‘Radar event announcem
Hint : requires the Perl Net::SMTP module to be installed.

• Run program
Runs an external program. Specify the full path to the program and any comma
line arguments. The program runs as the same user that is running Radar. In the
mand line, a number of positional parameters can be replaced automatically: %
replaced by the current time. %1 is replaced by the name of the event type (‘co
nected’, ‘disconnected’ etc). %2 is replaced by the name of the host reporting t
event. %3 is replaced by the text of the announcement message.
Hint : with most shells, you would have to put quotes around %0 and %2, since t
may contain spaces.
10 of  27 Radar Reference Manual
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7.3 Monitoring a new Radiator

When Radar starts for the first time, you will be presented with an empty screen sim
to Figure 4 on page 11. No Radiators are being monitored, and no monitoring tool
visible.

FIGURE 4. Radar just after it is started for the first time

In order to monitor a Radiator, you must first configure it into Radar. Before you ca
monitor a new Radiator, you will need to know the DNS name or IP address where
running, and its Monitor port number. You will also need to know a valid username a
password that can be used with the Radiator Monitor. If you don’t know this inform
tion, consult your Radiator server administrator.

To configure Radar to monitor a new Radiator, choose Tools->Monitor new Radiat
server.... You will then see a dialog similar to Figure 5 on page 11.

FIGURE 5. Enter host name or address and port number

Server list area:
Radiators being monitored
will be listed here

Tools area:
Monitoring tools will
appear here

Menus

Resize the server list
with this adjuster

Enter the DNS name
or IP address of the
server

Enter the Monitor port
number
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Enter the DNS name or IP address of the Radiator host. The default of ‘localhost’ me
‘on the same computer where Radar is running’. Also enter the port number that th
Radiator Monitor is listening on. The default port of 9048 is the same as the default
that the Monitor clause uses. See Section 6.0, “Radiator configuration,” on page 7
more details. Press Return, or click on OK. You will then see a login dialog similar 
Figure 6 on page 12

FIGURE 6. Enter Username and Password

Enter a valid Username and Password to authenticate the Radar connection to the
ator Monitor. If the Username and Password are accepted by the Radiator, you wi
the entry in the server list window change to loggedin, similar to Figure 7 on page 12
the Username and Password are not accepted, you will be prompted for them aga

FIGURE 7. Radar connected and logged in to Radiator

Hint : in order to automatically reconnect to the same servers next time you start R
save the current configuration with File->Save Radar Configuration.

Enter a valid User name
and password to
authenticate the
connection to
Radiator

New server is shown
in ‘loggingin’ state

Radar is connected
and logged in the
the new Radiator
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Hint : There is a right mouse button menu available on the server list window, contain
the same options as in the Tools menu.

7.3.1 Server states
After connecting to a Radiator, Radar continually monitors the health of the conne
Radiator. It displays information about the health of each connected Radiator in th
server list window. Radar can detect and display a number of different states of he

• disconnected
Red
The TCP connection to the Radiator has been broken or lost. Perhaps the Rad
has stopped running, or perhaps there is a network or TCP connectivity problem
between Radar and the Radiator.

• connected
Purple
A TCP connection has been established. Radar is waiting for a CHAP challeng
before it can start to log in. This is a normal stage while connecting or reconnec
to Radiator. It should only last for a second at most.

• loggingin
Blue
Radar is in the process of logging in to Radiator: it has connected by TCP and
received a CHAP challenge. It has sent a LOGIN command and is waiting for th
result.This is a normal stage while connecting or reconnecting to Radiator. It sho
only last for a second at most.

• loggedin
Green
Radar has successfully logged in. All the tools for that Radiator are now operatio

• stalled
Yellow
Radar is still connected by TCP but it has not received a response from Radiato
more than a certain interval of time. This generally indicates a problem with the
Radiator, since it will probably not be responding to Radius requests either

7.3.2 Changing server details
After adding a new server, you may want to change some of the configurable param
for that server. The default values that Radar uses for new connections are perfectly
able for most uses, but for advanced or unusual situations, you may wish to custom
them.

To change server details, click on the servers entry in the server list, then choose 
>Properties. A dialog similar to Figure 6 on page 12 will appear.
Radar Reference Manual 13 of 27
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FIGURE 8. Changing host monitoring details

You can change any or all of the server configuration parameters:

• Title
This is the name that will be used for the server in the server list. It defaults to t
hostname and port number, but you might want to change it to something that i
more meaningful for your organization, such as ‘Primary Radius’ or ‘Secondary
Radius’.

• User Name
The username that will be used to authenticate connections to this server.

• Password
The password that will be used to authenticate connections to this server.

• Ping interval
The time interval (in seconds) between attempts to contact the server. If the serv
not currently connected, Radar will attempt to reconnect after each interval. If th
server is connected and logged in, Radar will send an ID request each interval,
can confirm that the Radiator is running properly and is not stalled.

• Stalled time
The time interval (in seconds) to determine that a Radiator is stalled. If no resp
is received from the server for more than this time, it will be marked as ‘stalled’ a
the ‘stalled’ announcements (if any) will be made.

• Max clock skew
The maximum permissible time difference (in seconds) between the Radar hos
clock and the Radiator host clock. If this difference is exceeded, the ‘clock_ske
announcements (if any) will be made.

Alter server connection
parameters here

The server being changed
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Hint : in order to reconnect with the same parameters next time you start Radar, sav
current configuration with File->Save Radar Configuration.

Hint: use a time synchronisation system like NTP to synchronise the clocks on you
Radar and Radiator hosts.

7.4 Viewing the Trace message log

You can optionally display a Trace message logger for each monitored Radiator. T
allows you to easily see error and warning messages sent by Radiator, and optiona
enable debug messages, allowing you to analyze how and why Radiator is handlin
tain requests.

Radar Trace logging is in addition to and completely independent of any other logg
configured into Radiator. If you have your Radiator configured to log ERR message
a FILE, it will continue to do so irrespective of the settings of the Radar Trace logg

To view a Trace logger for a Radiator, click on the server in the server list, then ch
Tools->Trace log. You will see a logger window in the tools area, similar to Figure 9
page 16.

Radar can only show one logger per server. If you try to view a new one, nothing w
happen.

As Trace log messages arrive, they are scrolled upwards in the logger window, so 
most recent messages are always visible. The standard Tk text menu is available 
the right mouse button, allowing you to cut and search for text. All the messages
received by the logger are kept in the text buffer (and therefore within Radar) until 
logger window is closed.

Caution: this can mean that Radar memory usage can grow very large if you turn i
to debug logging on a busy server.
Radar Reference Manual 15 of 27
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FIGURE 9. Viewing a Radiator Trace message log

The logger window can be resized vertically at any time by dragging the adjuster in
lower left corner of the window.

You can change the Trace level for the Radar logger at any time with the level opti
menu in the logger window. Radiator then only sends log messages that are at or 
the trace level set by the trace level menu in Radar.

You can specify a logger Filter, so that the logger will only show messages resultin
from Radius requests that satisfy the filter and which are at or above the current T
level. To create or alter a filter, click on the Filter... button. A dialog will appear,allowin
you to specify one or more Radius attributes, values and matching rules. Only Rad
packets that satisfyall the rules will be logged to the Radar logging window. To acce
the new filter, click on OK. The filter rules wil be printed in the logger window, and th
new filter will take effect immediately.

FIGURE 10. Editing the logger packet filter

Radiator sends log
messages to Radar
according to the
setting of the level
option menu, and

Shows the ID of the Radiator
being logged

Resize the logger
Close the logger

the Filter
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7.5 Viewing statistics

You can optionally display and plot statistics gathered by each monitored Radiator
Radiator gathers over 20 statistical measures for the server as a whole, and for ea
Radiator object (i.e. for each Client, Realm, Handler, AuthBy and Host in the Radia
configuration). Radar allows you plot any or all of the available statistics from any or
objects within a Radiator.

Plotting statistics allows you to see, for example, when Total throughput is unusua
low, or if Average response time is usually high, indicating a problem in the authen
tion system. Many other interesting and useful statistics are also available, allowing
to keep close tabs on the health of your authentication system.

To view a plotter for a Radiator, click on the server in the server list, then choose T
>Plot statistics. You will see a plotter window in the tools area, similar to Figure 11
page 17. This plotter will show statistics gathered for the server as a whole.

To view a plotter for an object with Radiator, expand the server in the server list by
clicking on the +. The server will expand to show all the configurable parameters a
objects at that level within the server. You can drill down to see objects embedded
within other objects. For example, to plot statistics for a single Client, click on + next
the server name to expand it, then click on the + next to Client. It will expand to list
name of each Client in the Radiator configuration. Click on the Client name, then
choose Tools->Plot statistics. You will see a new plotter window in the tools area, s
lar to Figure 10 on page 15. This plotter will show statistics gathered for just that C

FIGURE 11. Viewing a Radiator statistics plot

Shows the ID of the Radiator
being plotted

Click here to alter the plotter properties
or to plot additional statistics

Close the plotter

Resize the plotter

Data item name
and pointer

Gap showing a time
when the server was not
connected, and no data
was available

Time Ticks
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You can have any number of plotters for any number of Radiator internal objects. F
example, you could have a ‘Total requests’ plotter for the server as a whole, a sep
‘Average Response Time’ plotter for the server as a whole, a ‘Bad authenticators in
accounting requests’ for a certain Client that is currently causing trouble, and a ‘To
requests’ plotter for a Host in an AuthBy RADIUS, showing how many requests ar
being proxied. Furthermore, each plotter can plot any number of the available stat
for that object at the same time. However, it isnot possible to have statistics from two
different objects plotted in thesame plotter. See Figure 12 on page 18, showing an
example of Radar plotting statistics for two different servers.

Note that if a Radar becomes disconnected or unavailable while being plotted, the
line for that Radiator will not be drawn while it is disconnected. This means there m
be gaps in the plot line reflecting times when there was no statistical data available
that server. This is normal behaviour for Radar, but the cause of the diconnection sh
be investigated.

FIGURE 12. Viewing multiple statistics plots

For each plotter, you can extensively customize what statistics are displayed and h
they are displayed. You can add and remove data items from the plotter, change c
and titles, and change the scale factors and plotting frequency.

Radar is plotting Total Requests for each of
two different servers
18 of  27 Radar Reference Manual
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To change the configuration of a plotter, click on the Properties button in the plotte
configuration dialog similar to Figure 14 on page 20 will appear.

The plotter configuration dialog contains two tabs. General (Figure 13 on page 19)
allows you to configure parameters for the whole plotter. Data Sets (Figure 14 on
page 20) allows you to configure each individually plotted statistic.

FIGURE 13. Changing plotter configuration General

The general tab allows you to configure the behaviour of the plotter as a whole.

• Title
This field specifies the title to be used to label the plotter window. It appears in 
bottom left corner of the plotter window, to the left of the Properties button. It
defaults to the ID of the server and the name of the object it is plotting.

• Plot every
Specifies how frequently statistical data is to be retrieved from Radiator for this p
Options range from 1 Second to 1 Day

• Y Scale
Specifies the range of the Y (vertical) scale. Options include ‘auto’, ‘0-1’, 0-10’, 
100’ etc. Auto means vertical scale will be automatically chosen according to th
maximum historical value of the displayed data, so that the data fits within the v
cal scale.
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FIGURE 14. Changing plotter configuration Data Sets

The Data Sets tab allows you to configure the look of each individual statistic display
On the left side, there is a list of available statistics from that object. Clicking on on
will show how it is configured on the right. The following options are available

• Show
Set this to make the statistic visible in the plotter. If not set, the statistic will not 
plotted.

• Show name as
Specifies an alternative name to use for this statistic in the plotter. Defaults to th
standard Radiator name for the statistic.

• Style
Specifies the way to display data points for this statistic. ‘Lines’ means join samp
with lines. ‘Dots’ means plot each data point with a single 1 pixel dot. ‘Solid’ me
plot the data as a filled solid vertical bar.

• Color
Specifies the color to use to plot this data item.

• Normalise
Specifies how to normalise the data for each statistic. Radiator provides the raw
surement of each data item. The most common choice is ‘per sec’ which shows
average rate per second. Other choices include rescaling up or down by factors o
allowing differently scaled statistics to be usefully plotted on the same scale.

List of available statistics
for this object

Configuration for this statistic
is displayed here
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The plotter window can be resized vertically at any time by dragging the adjuster in
lower left corner of the window.

Hint : There is a right mouse button menu available on the plotting area of the plott
window. It includes a Properties button. If you click the right mouse button close
enough to a data sample, it will show the name of the data item, and the time of the
ple.

7.6 Viewing Radiator parameters

Radar allows you to drill down into the monitored Radiators to view and possibly
change the Radiator configuration parameters. Click on the + next to a server in th
server list window causes the list to expand and show all the top level server config
tion parameters and clauses, similar to Figure 15 on page 21. Clicking on the + ne
an object or object list causes it to expand in turn. Using this technique, you can exp
the entire Radiator configuration.

FIGURE 15. Radiator with expanded parameter details

Many parameters display their current value next to them. You can resize and scrol
server list window to see more of the parameter list. Some parameters are not abl
usefully display all their data values. They will show up as ARRAY or HASH or simila

7.7 Changing Radiator parameters

Radar allows you to change selected Radiator configuration parameters. The chan
are not permanent: they only last until the next time the Radiator is restarted (i.e th
changes only effect the Radiator internal state). This feature allows you to quickly
experiment with changes to the configuration without constantly restarting the serv
For example, you can change the text of hooks, and set various flags, strings and 
gers in the configuration.

Click here
to expand
and see
internal server
configuration

Drill down into
sub-objects by
clicking here

Radiator configuration parameters in
alphabetical order
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To change a configuration parameter, expand the server details in the server list win
until you find the parameter you which to change.

Click on the parameter you are interested in, then choose Tools->Change Parame
Value... You will see an editing dialog similar to one of the ones shown in Figure 16
page 22, Figure 17 on page 23, Figure 18 on page 23 or Figure 19 on page 24.

FIGURE 16. Changing a flag parameter
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FIGURE 17. Changing a hook parameter

FIGURE 18. Changing a string parameter
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FIGURE 19. Changing an integer parameter

Edit or change the parameter, then press Ok. The dialog will disappear, and the ne
value for the parameter will appear next to the parameter in the server list window.

Using Radar you can only change some of the Radiator configuration parameters.
can change any string, integer, flag or hook parameter.

Hint : Not all parameter changes have an effect. For example, you can use Radar t
change the Radiator AuthPort, but this will not actually change the port Radiator is
tening on.

Hint : One of the more useful flag parameters for testing and debugging is the Pac
etTrace flag, available in each object. If a request passes ‘through’ an object or cla
with the PacketTrace flag set, Radiator will log at DEBUG level all the messages fo
that request, regardless of the current Trace level. This is useful, for example,  for 
ting detailed traces for requests coming only from a certain Client.

Hint : When changing a hook, details of any compile errors for the new hook can be s
by opening a logger window to that server at Error level.

7.8 Restarting a Radiator

You can manually restart any Radiator connected to Radar. To restart a Radiator, c
on its name in the server list window, then choose Tools->Restart Server. This has
same effect as sending a HUP signal: Radiator restarts by completely rereading its
figuration file.
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8.0 Security

Radar connections to Radiator are authenticated with CHAP. Plaintext passwords 
never sent on the connection. However, Radar connections are not encrypted. If yo
concerned about proprietary information being exposed by sniffing the TCP connec
you should consider tunnelling the Radar TCP connection using SSH or similar.

If you are using hardwired username and passwords in your Radiator Monitor con
ration, you should take care that unauthorized personnel cannot access the Radiato
figuration file to read the Radar access password.

The Radar configuration file may record the Radar access password for each Rad
saved in the configuration file. You should take care that it is not readable by unau
rized personnel. The Radar configuration file is in.radar.ini  in your home direc-
tory on Unix, and inradar.ini  in the current directory on Windows.

9.0 Getting Help

9.1 Support contract holders

Radar support may be purchased at the time you purchase Radar. Seehttp://
www.open.com.au/ordering.html  for details. Support contracts last for a lim
ited period (typically one year) and may include a limited amount of pre-paid email s
port.

Open System Consultants will respond promptly to support email during business
hours, Australian Eastern Standard time. Telephone support isnot provided. We will
keep track of the effort required to answer your support email, and inform you whe
your prepaid support time has expired.

If you have a Radar or Radius support contract, you may send email to

radius-support@open.com.au

Include your support contract identifier in the Subject line. If you don’t have a supp
contract, we will not respond to your query on this address.

If you need an urgent response outside of the standard email support hours, you m
want to post to the Radar mailing list instead. Someone will be sure to be awake s
where in the world.

9.2 No support contract

The standard Radar license does not include support, but it does include the full s
code and free access to the Radar mailing list. This means you can help yourself, 
you can work with other Radar users in the user community. In order to participate w
others in this effort, you can join the Radar mailing list by sending email with the sin
wordsubscribe  in the body (not in the subject line) to

radar-request@open.com.au
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After subscribing you can post to the mailing list by mailing to

radar@open.com.au

The staff of OSC monitor the Radar mailing list and frequently answer questions. I
very active so don’t hesitate to use it. There is an archive of the mailing list availab
http://www.open.com.au/archives/radar/

Please, don’t post HTML to the Radar mailing list. Not everyone is using HTML com
patible mailers.

9.3 What to do if you need help

Before you post to the support address or mailing list asking for assistance, we su
you go through the following check list:

1. Consult this reference manual.

2. Consult the FAQ at http://www.open.com.au/radar/faq.html for extra hints and u
to-date information.

3. Consult the mailing list archive athttp://www.open.com.au/archives/
radar/ for more hints. You can search this archive for items related to your pro
lem.

4. Check that you are using the latest version of Radar. See
http://www.open.com.au/radar/downloads, use the username and password we
issued to you. Upgrade if you need to.

5. Check whether there are any patches that address your problem. See the REA
file in the patches directory for your release at
http://www.open.com.au/radar/downloads/patches-*/README. Apply the patch
you think you might need it.

6. If you still have the problem, post to the mailing list by mailing to:
radar@open.com.au. I f you have a support contract, send email toradar-
support@open.com.au.
Be sure to include at least the following information:

• A detailed description of the problem.

• Your Radar and Radiator configuration files (remove any secrets and password
first).

• An extract from your Radiator log file (with Trace level of 4) illustrating the prob
lem, or at least what is happening at the time of the problem.

• Details of the computer type, operating system etc.

This information helps people to better understand your problem and help find a s
tion more quickly.

9.4 Announcements

There is a separate Radar mailing list that just carries product announcements an
upgrades. If you want to know about upgrades available, but do not want all the te
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announcements will be posted to both lists.

You can join the Radar Announcements mailing list by sending email with the sing
wordsubscribe  in the body (not in the subject line) to

radar-announce-request@open.com.au

9.5 Bug reports

We are interested in your feedback, both positive and negative, and bug reports. P
send them to info@open.com.au. Licensees are entitled to free upgrades, and we
bugs that are reported to us, so if you report a bug, you can expect to get an upgra
with a fix one day. If you don’t report it, it might never get fixed.
Radar Reference Manual 27 of 27


	1.0 Table of Contents
	2.0 Introduction
	3.0 Quick Start and Evaluation guide
	4.0 Deployment Architecture
	4.1 Single Host
	4.2 Multi Host
	4.3 Remote display

	5.0 Installation
	5.1 Requirements
	5.2 Unix
	5.3 RPMs
	5.4 Windows

	6.0 Radiator configuration
	7.0 Operation
	7.1 Command line arguments
	7.2 Configuration
	7.2.1 General
	7.2.2 Announcements

	7.3 Monitoring a new Radiator
	7.3.1 Server states
	7.3.2 Changing server details

	7.4 Viewing the Trace message log
	7.5 Viewing statistics
	7.6 Viewing Radiator parameters
	7.7 Changing Radiator parameters
	7.8 Restarting a Radiator

	8.0 Security
	9.0 Getting Help
	9.1 Support contract holders
	9.2 No support contract
	9.3 What to do if you need help
	9.4 Announcements
	9.5 Bug reports


